Checking DFS referrals in 10.7

So, I had an issue where I could map the DFS share manually in Finder, but it wouldn’t automatically mount on login

The machine in question was bound to the Active Directory Domain, the DFS shares were hosted on other servers bound to the Domain Controller, so I opened Terminal & entered this to check that the referrals were working correctly

smbutil dfs smb://root.dfs.namespace/DfsRoot/DfsLink

this showed that the Mac was only looking to the Domain Controller for DFS shares/namespaces

To resolve this problem we started up the DFS Service on the Domain controller and added the DFS namespaces to it

check out this Microsoft article for how to do this

http://technet.microsoft.com/en-us/library/cc732807.aspx

After this had been done I opened Terminal and ran the command above and this time it returned my DFS namespaces, rebooting the Mac and logging back in resulted in the drive mounting automatically

DFS Network Home – Question Mark in Dock

If you have logged into a domain account and there is a broken link (question mark) in the Dock pretending to be your network home folder then you will need to edit your DOMAINNAME.plist to prevent this. (Where you see DOMAINNAME, replace this with the name of the domain you are connecting to)

First, copy /Library/Preferences/OpenDirectory/Configurations/Active Directory/DOMAINNAME.plist to your Desktop

Change the permissions so you can edit the file

Find the key:

AddDockMCXOriginalNetworkHomeFolder

& delete it

Then in Terminal enter the following command to restore it to its correct location

sudo cp DOMAINNAME.plist /Library/Preferences/OpenDirectory/Configurations/Active Directory/DOMAINNAME.plist

reboot and log in to a domain account and all should be well, no question mark in the dock